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Resistivity Surveys

This guide is based on training and notes provided by Peter Masters of Cranfield University.
Some additions and amendments have been made by Jigsaw Cambridgeshire to adapt the
guide for our volunteers; any errors are our own. Thanks to David Staveley for creating this
free user-friendly processing software.

Snuffler is an excellent freeware alternative to commercial software packages such as Geoplot
and TerraSurveyor (formerly Archeosurveyor) used by professionals as it offers similar features
(destriping, interpolation, creating greyscale maps) and functionality (e.g. downloading data from
instruments).

Installation ,
Snuffler can be downloaded at

http://www.sussexarch.org.uk/geophys/snuffler.html ~ Welcome to the Snuffler Setup Wizard

1. Under ‘Page Index’, click on ‘Download’. The
current version is 1.12. Where it says
‘Download the file here: snuffler.zip (5.6Mb)’,
click on ‘snuffler.zip’ and select ‘Save file’. Once
downloaded, save the .zip file into a folder of
your choice (e.g. C:\Snuffler) and double-click
on ‘snuffler.zip’ to open the file. Then double
CIiCk on ‘Setup_exe’ f||e A Standard WindOWS— Snuffler is Freeware, distribute as you please as long as you do not chnage it or charge for it.
type installation wizard will pop-up (see right).

Follow the instructions to load the program.

The installer will guide you through the steps required ta install Snuffler on your computer.

Cancel Back l Next > I

2. It will also ask you for the installation folder (e.g. b i
nstalling snuttier

C:\Snuffler). Click on ‘Next’ to start unpackaging the
program.

Snuffler is being installed.

(It is important to note that Snuffler works fine

Please wait...

running Windows XP but you might find that some
functions may not work as well with Windows 7 and
8.)

3. Once the installation is complete, a
Snuffler shortcut should appear on your

Desktop (see right). Double click on it to

run the program. U o | o



http://www.sussexarch.org.uk/geophys/snuffler.html
http://www.sussexarch.org.uk/geophys/snuffler.zip

— e ]
T ¥ )
ek . AT | lottery

ey r =

g LOTTERY FUNDED

Create a project

Once Snuffler is installed, create a new project. Go to [
File>New Project (see right). A pop-up menu will appear
(see below). Name your project something memorable View Help

- Snuffler

and click on ‘Create’. Your project name will appear in Mew Project ]
the left margin in Snuffler. Open Project... N
" Save Project
Mew Project ﬁ Close Project
Project Mame: || =
Open... Ctrl+0

—r

| Help | Caricel |

Importing/Downloading Data

There are two basic ways of entering geophysics data into Snuffler. One is to directly
download the data from the Geoscan RM85 instrument and the other is to import previously
downloaded data in ASCII (.dat, .xyz, .txt) format into your project.

Method 1: Direct Downloading

1. Connect the RM85 to your computer using the Data Dump nine-pin cable. If your computer
doesn’t have a nine-pin cable, you may use the green USB adaptor, but it is not always
possible to download using this. To ensure good results, use an old PC or laptop with a nine-
pin female Comm Port, or borrow the Jigsaw laptop. Don’t turn on the RM85.

f -~ Snuffler
2. In Snuffler, select File>New>Import file (see View Help
I’Ig ht) New Project !

Open Project...
Save Project

Close Project

New » Geophysics Data File
Open... Ctrl+0 Data Preview File
Close View File
Save Ctrl+5 Map File
Print Sctup... Import File
I
‘ y . . jeter Im @
The ‘Meter Import’ menu will appear (see right). [ ==
Select the following: Imparttame [rzsidata G Seltines
etres Fieadings Per Metre
Hardwate | RM15/MP15/AMB5 RESTIVIT ¥ | sorolne @ T
¢ Import Name: give a slightly different name CommsPor [CoW 7] T i
to above, e.g. testdata. BadRate [0 %] -
e Hardware: ‘RM15/MPX15/RM85 i =
RESISTIVITY METER, Import Guantity—  Quantity Start Position S S
. ) T Grids nid Splt
e Comms Port: this refers to the port in the - o ° ! T —
computer into which you connected your © Restings | ' Gidpes [l

i

RM85 Data Dump cable. Select the Comms
Port) eg COM1 If you don’t knOW WhICh Connect the RM15 to the computer using the serial lzad and tum the RM15 on.
port it is, you may be able to check this in || 525k 2ot e e

Press DUMP an the RM15 keypad.

the DeVICG Manager on a WIndOWS OS Once the download iz complete, tum off the RM15
Alternatively, use trial and error — if it

Instructions For This Hardware

2 Help Cancel
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doesn’t download with COM1, try COM2 etc.
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e Grid Split: check the ‘Split into Grids Now’ box to avoid data mix-ups later on.

e Grid Prefix: file name again e.g. ‘test’.

Follow the instructions at the bottom of the ‘Meter Import’ box to complete

download.

3. If download has been successful a Data Order Selector box appears (see

right). Untick ‘horizontal progression’ and it should go up and down from

bottom left.

4. Turn off the RM85.

Method 2: Importing Previously Downloaded Data

Data Order Selector El

(s ('“

b

i i

[¥ Harizantal Progression
|v Bi-Directional

Help |

[u]:8 | Cancel |

Snuffler can process data from imported files (e.g. if [ soumer

you ask Jigsaw to download the data into Geoplot, |[Fe] view Hep

we can send you the data files to process in
Snuffler).

1. Make sure the files you want to upload are in the
correct folder. Save the .xyz or .dat file as 20x20
not 80x20 (4 readings/m) in Geoplot. Import .xyz
data into Snuffler by putting it into Program Files
(x86)/Snuffler folder.

2. File>Import>Easy XYZ Import Into New File
(see right). Navigate to the folder your files are
stored in and select your first file. A new box
appears (see below):

MNew Project
Open Project...
Save Project

Close Project

New
Open...
Close

Save
Print Setup...

Options...

Project Options...

Project MetaData...

Import

1 C\Usersh..\test3\test3 spr

2 C:\Usersh.. \test\test.spr

3 C\Users\..\Gamlingay0L.spr
4 C\Users\..\warbg'warbg spr

Exit

Ctrl+O

Cirl+5

»

Easy X¥Z Import Into New File
Import EPE Mag Grid

f Easy XYZ Import l&r

Mame [testll

0,0 Origin Dimenzions

€ TopLeft ' BottomLeft # Dimensions ' Dimensions

Metres |2D |2D

Durnmy Y alue

" AllOf The Below

Feadingz/Metre |'I |'I
" Non-Murmeric Dnly

" Zem

+ 20475 [Geoplot]

" Other Durnrmy Yalue 0

Cancel

e Dummy
(Geoplot)

Origin: ‘Bottom-Left’
value: 2047.5

3. Continue in this vein until all
the required files have been
entered into your project.
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Creating a Composite
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O Snuffler
Once your data has been incorporated into your Snuffler || File View Help
project you can preview each grid. To the left of your file D= PN
name you will find a ‘+’ sign. Click on this, and the title =
‘Geophysics Data’ appears. Click on the ‘+’ sign next to this B test3
as well, and the file names of each of the grids uploaded are &-{E] Geophysics Data
listed. Right-hand click on the name of the grid you wish to i 501
preview, and select ‘Preview Window’ (see right). A sneak L=
preview of your grid will appear. Preview Window
Spawn Main View
Delete File
Export Data
Rename File
[
In order to view all the data in one view a composite needs to be created:
1. Goto File>New>Map File (see right). [ 7 Snuffier
View Help
The ‘New Map’ box appears (see below): New Project
Open Project...
“ Save Project
MNew Map @ Close Praject
New 3 Geophysics Data File
MEII:I M ame ||IES|ZI3I:IIT||:I Open... Ctrl+Q Data Preview File
Cloze View File
Save Ctrl+5 Map File
Map width |3 —— Import File
Options...
|"-"|EI|:I HEight 2 Project Options...
Project MetaData...
] | Help | Cancel
T o
e Map Name: e.g. ‘testcomp’.
Map Width and Map Height: this refers to the layout and number of the 1 2 3
grids you surveyed. For example, the diagram on the right represents the
Map Width: 3 and Map Height: 2.
6 5 4

Press ‘OK’. The following box appears:

=

ll"f} testcomp
- Empty - - Empty - - Empty -
- Empty - - Empty - - Empty -

2. Now you need to attribute each
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grid to its proper location. Left-hand click on one of the ‘Empty’ grids. A ‘Select Data Source’
box appears. Select a filename to fill this box according to the order you surveyed the grids
in, e.g. see below.

=

ll"f} testcomp
testll - Empty - - Empty -
- Empty - - Empty - - Empty -

3. Once the grids have been configured into their correct positions you can close the
Composite file (the program will ask you whether to save the file — select ‘Yes’).

4. Click he ‘+ si ‘Maps’, right-h
Click on the sign next to ‘Maps’, right-hand —— | 53
and select ‘Spawn Main View'. Give it a new

click on the composite filename (e.g. ‘testcomp’)
filename, e.g. testcompView (see right) and click Filename: |testeompliew
‘OK.

Cancel

You should now be able to view all your data.

Processing Resistivity Data

Another algorithm that can make the visualization clearer is the “Despike” filter that removes
small dipolar anomalies that are caused by ferrous detritus in the topsoil and also by bad
instrument handling during measurements. The application of this filter requires the input of a
threshold and type of flattening effect. Caution is advised as too much filtration in this case will
cause a great amount of false data to be incorporated into the plot.

Despiking - e
Fil Hel
Go to Filters> Remove Spikes (right). liters | Help

Remove Geology
Remuove Spikes

Interpolate

“
The ‘Despike’ box appears (right). Experiment with the settings. ‘Sit | Despike lihj
on it like a moose’ means ‘heavy despiking’ so select this option if you
suspect the instrument wasn’t handled well (e.g. in first or second time Threshald  |1.0
the operator used the RM85), or if there was a high magnetic content
in the topsoil. Flattening Effect

" Light
* Momal
" SitOn It Like & Mooze

Help |

] Cancel |
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Remove Geology
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The Remove Geology feature removes the uneven background which is caused by the
underlying changes in the near surface geology. The application of this filter should be used with
caution as you could remove archaeological data not just the background variations.

Mean Sample Size @
Go to Filters>Remove Geology. The ‘Mean Sample
Size’ box appears. Experiment with the settings, but the o
recommended setting to use would be 5 (see right). _I
1 5 10
] 4 | Help Cancel
M
Interpolation
After data defects have been removed, the dataset can now be interpolated: new data is
added to give it a smoother look.
w
Interpolate @
Go to Filters>Interpolate. The ‘Interpolate’ box appears
grrl]%hg.icfgﬁ’s-,e Interpolate Horizontally and Vertically |Inter|:u:||ate Rerizontaly & Verticaly j
ak. | Help | Carnicel |

Contrast & Colour Manipulation

Snuffler offers a few basic display types and processes. These can be switched on by

selecting the following:

1. Select Display>Next Process Type (see right). This
changes the type of visualization type from dot density to
relief map. If you repeatedly select Display>Next Process
Type you can scroll through the different available views.

Display
Display Settings

Mext Process Type
Mext Display Type

Reverse Display

Display Grid

Info  Filters Help

ALT+D
ALT+M
ALT+T
ALT+R
ALT+G

Set Clip To Selection

ALT+C

2. Select Display>Next Display Type. This changes the colour pallete
used to visualize data. Again, if you repeatedly select Display>Next
Display Type you can scroll through the different available views, e.g.

see right.

. Snuffler - [ruffcompositeView]
[ File Edit View ndow
D& el =s)

x &

isplay Info Filters Help

a8 ruffordproject
2157 Geophysics Data
G

[& ruffcompositeView2 |
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3. Another thing that can be done in order to  FEmw= =
adjust the display type to your needs is | g2 Displysing [ %0fReadngs Sl wedion [ -

FRE - T
I~ Auto Recalc Using bove  Invalid |Yellow ~v| T InfoOnScreen |7 Cent

the contrast manipulation of the data. —BE]

Select Display>Display Settings. The | =
‘Display Settings’ box appears (see right): | &,

oK | Grid Settings Image Propetties Relief Plat NonLineat Pl Help Cancel

Snuffler by default uses the ‘Auto Recalc Using Above’ option. You can turn this off by
unticking the box next to it, and entering your own range of data to compare the results.

E.g. enter Low: -10 and High: 10 and note the different level of information that is now
visible on your magnetic map. You can also choose the Display Process and Display Type
directly from this menu.

Adding grid lines

To enhance interpretation, you may find it useful to add
the original grid lines to your data. This can be
achieved by clicking on the ‘Display Grid’ icon (see
below). Your data should now have grid lines as shown
in the image (right).

Display Grid icon
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Exploring data: measuring distances & angles

Snuffler also provides basic measurement tools for further interpreting the data. These can
be accessed from the icons on the toolbar.

Measure Angle icon. Select this and then click on two points on the data which
4 you wish to measure the angle between.

Measure Distance icon. Select this and then click on two points on the data
Lot which you wish to measure the distance between.

You may find it useful to use the Increase Mag (zoom in) and Decrease Mag (zoom out)
buttons to calculate angles and distances between points more accurately.

Another very helpful feature in Snuffler is the ability to see the coordinates and geophysical
signal of the place currently below the cursor. This is shown in the lower left corner of the
window (see below, marked by the red rectangle). As you move the cursor around over the
image the different readings will be shown.

ij File Edit View Window Display Info Filters Help
PEE8 2R [[fHRON LD SHF D cw CWia IE==EBE

8- 63?.. RedBarrow

=] . Geophyslcs Data
i red20
. red21
red22

1 red27

| red28

| red34
red29

7 red35
7 red36

o @ s

. .48 Redcomp
. @-[& Main Views

20 20 [ [

X: 402 (50.25m) Y:102 (51.00m) DATA: -0.11
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Raster Exportation & Further Possibilities

Unfortunately in its current form Snuffler does not possess features that allow for the
construction of a sensible print plot nor has it any drawing/vectorization tools. Fortunately
there is other freeware and open source software available such as QuantumGIS (QGIS)
that used in conjunction with Snuffler allow for a fully professional & georeferenced plot to be
created.

In order to transfer our filtered data into third party software a raster of the acquired
geophysical image needs to be exported. Snuffler currently only supports the .png format.

Go to File>Export>PNG File (see below)

Project MetaData... |

Export r To Text File
Import 2 To X¥Z File
1 RuffAbb.spr To VRML
2 Ch\Usersh..\barhill.spr PMG File

A ‘Save As’ box appears. Give your file a suitable name and click ‘Save’. The saved file can
now be imported into graphics software programs such as QGIS or printed and distributed in
this form.



